Pictures, Video, or other Web Content Blocked

Pictures, Video, or other Web Content Blocked:

Symptom:

Pictures, video, or other web content on a web site is blocked or not being displayed even though you have explicitly allowed the website or its category rating.

Cause:

Pictures, video, and other web content often loads from a different web server than the page you visit. This other web server may belong to a category your K9 filter policy is set to block.

Solution:

We will use www.facebook.com as an example in this solution. When you visit www.facebook.com, many of the pictures are actually being loaded from the following web server:

creative.ak.fbcdn.net

For future reference, this URL can often be found by right-clicking where a blocked picture should have loaded and selecting "Properties." A window should appear that lists the actual address of the picture itself. Once you find the picture's URL, copy and paste it into the address bar of a new web browser. K9 will most likely block the picture and display the reason why it was blocked.

An alternative method for discovering why K9 is blocking a URL is as follows:

  1. Clear the logs (counters) in the [View Internet Activity] section of the K9 Administration Tool.
  2. Reproduce the problem you are having. Hint: you can force the web page that is having a problem to re-load by pressing CTRL-F5 or SHIFT-F5 (depending on your web browser). Doing this will cause K9 to block the picture or video again.
  3. Return to the [View Internet Activity] within the K9 Administration Tool.
  4. At least one category should be red, indicating that K9 has blocked a URL belonging to that category. Note that some pictures might be blocked because the "Block Unrated Web Pages" option is enabled.

The Facebook content URL listed above is rated as "Content Servers", which is defined by Blue Coat as:

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Servers that provide commercial hosting for a variety of content such as images and media files. These servers are typically used in conjunction with other web servers to optimize content retrieval speeds.

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In this case, the rating is correct. Once you discover the reason content is being blocked on a website, you have a few options:

  • Configure K9 to allow the blocked picture (and all pictures on the same web server) by adding it to the [Always Allowed] exceptions list, or simply overriding it permanently on the previously mentioned K9 block page.
  • Configure K9 to always allow websites from this blocked category. Please note that some pictures might be blocked because the [Unrated] category is set to be blocked and Blue Coat may have been unable to determine a rating for the web server where the pictures are stored.

If you feel the picture URL is incorrectly rated, please click here for instructions to submit this URL directly to our ratings team for review. To do so:

  1. Launch K9 from your [Start] menu. Alternatively, you can navigate directly to http://127.0.0.1:2372
  2. Click [Get Help].
  3. Click [Check/Dispute Site].
  4. Alternatively, you can use the form on our website at http://www1.k9webprotection.com/support/check-site-rating.php
  5. Enter the URL of the web site in question and click [Submit].

After you submit the URL, you will be given the current categorization of the site, as well as a form you can complete to request a category change. Please be very specific in your description as to why the URL should be rated differently. Our ratings team is usually able to review your submission within 48 hours, and will email you back with the decision if you choose to provide an email address.