K9 Web Protection Not Responding (Mac)

Symptoms
On a Mac computer you cannot access the Internet and you receive an error stating "K9 Web Protection Not Responding"

Cause
This issue is caused by one of four things:

  • Your K9 Web Protection installation has been tampered with in an effort to bypass filtering.
  • K9 has been uninstalled incorrectly.
  • Another program is preventing K9 from working properly.
  • Your K9 installation has become corrupt because of another program or a bug in K9.


Solution

NOTE: You should never need to restore or reinstall Mac OS X to resolve a problem with K9. The K9 Support Team can always help you resolve a problem like this; however, we ask that you please perform the following steps before contacting K9 support:

  1. Reboot your computer and see if that resolves the problem.
  2. If rebooting does not help, click the spotlight search icon to the left of the clock and type "terminal" (without quotes) and press Enter to open the terminal.
  3. In the Terminal, type "ping google.com" and press [Enter]. After a few seconds, you should see lines similar to the following:

    PING google.com (64.233.187.99): 56 data bytes
    64 bytes from 64.233.187.99: icmp_seq=0 ttl=238 time=83.924 ms
    64 bytes from 64.233.187.99: icmp_seq=1 ttl=238 time=81.969 ms
    64 bytes from 64.233.187.99: icmp_seq=2 ttl=238 time=86.508 ms
    64 bytes from 64.233.187.99: icmp_seq=3 ttl=238 time=85.305 ms
    64 bytes from 64.233.187.99: icmp_seq=4 ttl=238 time=83.296 ms
    64 bytes from 64.233.187.99: icmp_seq=5 ttl=238 time=78.790 ms
    64 bytes from 64.233.187.99: icmp_seq=6 ttl=238 time=80.276 ms
    64 bytes from 64.233.187.99: icmp_seq=7 ttl=238 time=83.255 ms
    64 bytes from 64.233.187.99: icmp_seq=8 ttl=238 time=82.626 ms

    You can simply quit the Terminal program after running this test.

    If you DO NOT see information similar to above, something besides K9 is blocking your access to the internet (since K9 cannot block PING requests). Please investigate other potential causes.
  4. If you DO see information similar to above, your ping was successful. Please shut down every software firewall (and other security software) running on your computer. Some firewalls will cause problems when K9 is installed unless you change some settings in your firewall.
  5. If you are able to access the internet after shutting down your firewall, please configure your firewall to "always allow" K9 to access the internet.
  6. If you still cannot resolve the problem, please try these final steps before contacting K9 support:
  • Uninstalling K9
    Note that you must have administrator rights to uninstall K9. To uninstall K9 from your Mac, please open the System Preferences panel. Please click the K9 Web Protection icon in the "Other" section at the bottom, then click the Uninstall button.You will be prompted for your K9 password, and then your Mac user account password. Uninstallation may take a minute or so. When it is complete, you will receive a message that K9 has been successfully uninstalled. DO NOT ATTEMPT TO UNINSTALL WITHOUT A PASSWORD. By design, K9 will block all web access should anyone attempt to uninstall without using a password. Attempts to modify K9 at the system level will have the same effect. If you forgot your password, you can request one using the "forgot password" near the password box during uninstallation.
  • Reboot your computer
  • Reinstall K9

If the un-installation will not proceed, please contact support. Be sure to explain the following in detail:

  • The steps you took to troubleshoot the issue.
  • The results you received, including any error messages.
  • Include your K9 license number. This can be found in your license email, or under the title "user license" when you click the link below (or enter the address in a web browser on the affected computer): http://127.0.0.1:2372/about

We appreciate you taking the time to perform the steps above before contacting K9 support.

To contact support regarding this specific issue, please use this link.